Skip to toolbar


NEW MEMBERS - REGISTER HERE


Membership is FREE!
It is best to log in before posting. Anonymous posting is disabled.

SX KN 1500 MIDI ports Not working

Hi, I own a SX KN 1500 and I am trying to use as a midi keyboard for GarageBand in macOS. My set up is the following I connect the keyboard through a MIDI to usb cable, the problem is that i don't see any data to come from the keyboard or the other way …

  • Home
  • »
  • Forum
  • »
  • SX KN 1500 MIDI ports Not working
Viewing 1 to 7 (7 Total)
SX KN 1500 MIDI ports Not working

romanos

romanos
Greece

Total Posts: 3
Joined: July 14, 2019

Hi, I own a SX KN 1500 and I am trying to use as a midi keyboard for GarageBand in macOS.
My set up is the following
I connect the keyboard through a MIDI to usb cable, the problem is that i don't see any data to come from the keyboard or the other way around.
Do i miss something in the setup of the keyboard as midi keyboard, or is it because it's an old instrument doesn't meet the knew standards
?Any help would be appreciated

Tags: SX KN 1500, MIDI keyboard
Posted on July 14, 2019 at 1:36 PM
Display Messages: Threaded     Flat
6 Replies

admin

admin
United Kingdom

Total Posts: 1101
Joined: February 2, 2014

Re: SX KN 1500 MIDI ports Not working

Hi Romanos,

KN1500 definitely works as a good controller with Garageband. Refer to the midi settings at Page 111 of the user manual which you can download in the members area. You'll also need the reference guide, again in the members area.

Make sure your midi connections are clean.

IN usually connects to IN and OUT to OUT but it varies between midi interfaces.

I have had no luck with cheap midi interfaces, the Roland and Yamaha interfaces work well. Most problems arise from using other brands of midi interfaces.

Best wishes,
Mike

Posted on July 14, 2019 at 10:10 PM

romanos

romanos
Greece

Total Posts: 3
Joined: July 14, 2019

Re: SX KN 1500 MIDI ports Not working

Thank you very much for your fast reply. I have read the manual at page 111 but I don't understand what settings I should use in order to play the notes from the keyboard
and hear it from GarageBand. For example should I go to MIDI Presets and choose KN->external sequencer? Sorry if my questions are silly but it is the first time I am trying to use my keyboard as a MIDI keyboard and I don't know the details of a set up like this.
Thanks for once more for your time.

Posted on July 15, 2019 at 12:34 PM

admin

admin
United Kingdom

Total Posts: 1101
Joined: February 2, 2014

Re: SX KN 1500 MIDI ports Not working

Your questions aren't silly, it is not easy to understand how to set it up but then it is straightforward once you know how.

My son is the Mac expert I'll ask him to comment and I'll join in to help with the Technics side of the setup if necessary. I'm very busy in my day job until the weekend so I'll look at the manual then if I need to (usually the settings will work straight out of the box and the adjustments necessary are on the computer). I don't have a KN1500 here so I'll need to refer to the manual when i have time.

Best wishes,
Mike

Posted on July 17, 2019 at 3:36 AM

AlexSealey

AlexSealey
United Kingdom

Total Posts: 5
Joined: January 19, 2015

Re: SX KN 1500 MIDI ports Not working

Hi there! I should be able to help you with this.

First of all I would try searching google for your USB MIDI interface. Usually Mac's have drivers built in but sometimes they will need extra drivers downloaded. Also, I have noticed any time I have used a generic USB MIDI interface they do not work. As my dad suggests I would get a Roland or Yamaha one, some audio interfaces/external sound cards also come with MIDI ports on them

Next we want to check if the Mac is noticing the MIDI interface. With the midi interface plugged in, go to your applications folder/spotlight/launchpad and look for an application called 'Audio MIDI Setup' (usually sound in the utilities folder). Click 'Window' at the top left of the screen or hit 'cmd 2' to show the 'Midi Studio' window. In that window you should be able to see small boxes showing every midi device you have ever plugged into your mac. If there are too many to make sense of, click the background, click 'Edit', 'Select all' and then press delete. Then press the refresh button at the top of the window.

If there are no MIDI devices available then either the driver is incorrect or the device is incompatible!

If the MIDI interface does show up and is highlighted (not greyed out) then that means it is online and should work properly. The other thing we want to make sure is that the keyboard is in general MIDI mode. Take a look at pages 113 and 120 of the manual for instructions on how to do that.

If everything I have mentioned above works then there is no reason that GarageBand won't work. GarageBand is very simple in terms of it's MIDI capabilities, it listens to all MIDI commands. Because of this, as long as the interface and keyboard are setup correctly it should work without any issue

Let me know how it goes!

Posted on July 17, 2019 at 3:58 PM

romanos

romanos
Greece

Total Posts: 3
Joined: July 14, 2019

Re: SX KN 1500 MIDI ports Not working

Hi AlexSealey,
Thanks in advance for your time.
As far for the Mac MIDI interface I can see that when I plug in the MIDI cable to the usb port of my MacBook it is highlighted, so the drivers of my MacBook are ok, also the led which is tagged as OUT on my MIDI cabled shows on.
Now for the keyboard.,I have noticed that when I plug the MIDI cable to the MIDI ports of my keyboard I don't see the led on my MIDI cable which is tagged as MIDI to light up, even if when the keyboard is set to General MIDI mode. So I thing that no signals are been sent from my keyboard.
An other thing that I have also tried was to connect a more recent keyboard to my MacBook pro through the same MIDI cable. In this case it works with the GarageBand but when I press more the two keys simultaneously they are kept pressed for ever, also if I play to fast some keys are not sent to the GarageBand.
So what do you think is it a problem with my keyboard or is it a problem with the cable?

Thanks once more for your help.

Posted on July 18, 2019 at 1:43 PM

Davi3D

Davi3D


Total Posts: 1
Joined: July 31, 2019

Re: SX KN 1500 MIDI ports Not working

Hey Romanos,

I own the sx-KN720 wich is of the same line as the KN1500. I personally didn't have problems connecting it to my PC (and I didn't need General MIDI mode) but one of the things I ran into early in my MIDI endeavors (so to say) was plugging the MIDI OUT of the interface into the MIDI OUT of the piano/device. It's a simple and understandable mistake to make.

So make sure you plug the MIDI OUT from your interface into the MIDI IN of your KN1500 and the MIDI OUT of your KN1500 into the MIDI IN of your interface.

I hope it was as simple as that.

All the best,

David

Posted on July 31, 2019 at 11:06 PM